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Welcome to Tsune’s documentation!

This project is a web application for managing and learning flash cards.
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1. Introduction

The goal of this project is to create a platform for people (especially students) to learn, create and share
flashcards. There will be achievments, badges, duels and random pop-culture references.


1.1. Getting ready to develope

Our development setup includes VirtualBox, Vagrant and PyCharm and we use Heroku for deployment. See Setting up a development environment for a detailed guide.




1.2. What does Tsune mean?


“Tsune is usually used in a more mundane context, such as brushing one’s teeth
regularly. But in the martial arts it refers to a state of such complete assimilation and
involvement that training becomes a natural and automatic part of one’s daily life.
Before tsune is achieved, the student often must struggle to make the practice schedule fit
into his everyday lifestyle; an endless number of factors will seem to hinder and obstruct
one’s practice routine. Some people are never able to accommodate regular training, and
thus never pass this stage.

For those who persevere, however, tsune gradually takes over. A state is reached in
which it is no longer necessary to think about disciplining one’s self to practice. The
training becomes as automatic and as accepted as getting up in the morning, getting
dressed and having breakfast. Now the feeling of awkwardness, the feeling that
something is not right, comes only when a practice session is missed. At this point the
martial artist has achieved a comfortable level of oneness with his art, and has fully
integrated it into his life and his personality. This is also the happy situation which yields
the greatest personal rewards. “

Wendell E. Wilsion (2010) (Source [http://www.minrec.org/wilson/pdfs/Training%20-%20Tsune.pdf])
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2. Setting up a development environment

This guide will help you set up a working development environment for
Tsune


2.1. Requirements


	A working and configured [https://help.github.com/articles/set-up-git] Git (download [http://git-scm.com/download/win])

	VirtualBox compatible [http://docs.vagrantup.com/v2/virtualbox/index.html] with Vagrant
(download [https://www.virtualbox.org/wiki/Download_Old_Builds_4_2])

	Vagrant (download [http://downloads.vagrantup.com/])

	PyCharm Professional
(download [http://www.jetbrains.com/pycharm/download/index.html])

	VirtualBox installation folder in PATH environment variable






2.2. Setting up Vagrant


	Open PyCharm

	Select Open from Version Control

	Select either Github or Git and input the repository information

	When asked whether PyCharm should open the project for you, select
Yes

	Select Tools > Vagrant > Up and wait for Vagrant to finish.
This will take a long time (~30min), so grab a coffee or get some
sleep. When it’s finished, you will see Process finished with exit
code 0






2.3. Setting up the remote python interpreter


	Select File > Settings and click on Project Interpreter >
Configure Interpreters

	Click the + button on the right and select Remote...

	Click Fill from vagrant config and Ok

	Click Test Connection. Answer the authenticity warning with Yes
and click Ok

	Click Ok to close the interpreter setup and wait for the process to
finish. This may take a few moments

	When asked whether you want to set the interpreter as Project
Interpreter, select Yes

	Click Ok to close the settings window






2.4. Configure Django integration


	Select File > Settings and click on Django Support. Make sure
that Enable Django Support is ticked



	Click the ... button next to Settings. Select
tsune/settings.py. Click Ok



	Close the Settings window with Ok



	Click Run > Edit Configurations



	If Django server has an entry named tsune, select the entry and
continue with step 7



	Click the + button. Select Django server



	
	Configure everything exactly as follows:

	Name: tsune
Host: 0.0.0.0
Port: 8000
Run Browser: http://127.0.0.1:8080







	Close the Run configurations dialog by clicking Ok
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3. Deploying Tsune...


3.1. ...to Heroku

To deploy Tsune on Heroku, just push the repository to it:

$ git push heroku master

After that, you should set the SECRET_KEY environment variable.
To generate a new key, run the following from a python prompt:

from django.utils.crypto import get_random_string

chars = 'abcdefghijklmnopqrstuvwxyz0123456789!@#$%^&*(-_=+)'
print get_random_string(50, chars)





Now set the SECRET_KEY environment variable for your app.
Run the following in your repository root:

heroku config:set SECRET_KEY="paste the generated key here"




3.2. ...on Ubuntu Server


	$ sudo apt-get update

	$ sudo apt-get install chef

	Do not input anything when prompted to select a chef-server. Just press Enter.

	wget https://dl.dropboxusercontent.com/s/pcnysdzaie6wr58/postgres.json

	chef-solo -j postgres.json -r https://dl.dropboxusercontent.com/s/fh3dxy0tbjuoulm/dependencies.tar.gz

	sudo apt-get -y install libpq-dev python-dev firefox xvfb graphviz git-core

	``git clone https://github.com/DummyDivision/Tsune ``

	cd Tsune && python manage.py syncdb && python manage.py migrate && python manage.py runserver
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4. Tsune Requirements and Dependencies

This document lists all requirements and dependencies necessary to deploy Tsune. At the time of writing, all of them
get downloaded automatically when you deploy out of the development environment.


4.1. Python Packages

1. Django [https://www.djangoproject.com/] is a high-level Python Web framework that encourages rapid development
and clean, pragmatic design.


	Gunicorn [http://www.gunicorn.org/] is a Python WSGI HTTP Server for UNIX.






4.2. Django Apps

1. Django Guardian [https://github.com/lukaszb/django-guardian] is an implementation of per object permissions
as authorization backend.
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5. User FAQ


5.1. How do I add a deck?

Click on the “+”-symbol in the “Deine Decks” overview.




5.2. How do I add cards to a deck?

Click on “Karten anzeigen” in the “Deine Decks” overview. All cards in the selected deck will be displayed. At the
end of the last row of cards is a “+” Symbol. Click it to add a card.
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tsune Package



local_settings Module





settings Module





urls Module





wsgi Module


WSGI config for tsune project.


This module contains the WSGI application used by Django’s development server
and any production WSGI deployments. It should expose a module-level variable
named application. Django’s runserver and runfcgi commands discover
this application via the WSGI_APPLICATION setting.


Usually you will have the standard Django WSGI application here, but it also
might make sense to replace the whole Django WSGI application with a custom one
that later delegates to the Django one. For example, you could introduce WSGI
middleware here, or combine a Django application with an application of another
framework.
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memorize Package



admin Module



		
class memorize.admin.PracticeAdmin(model, admin_site)[source]


		Bases: django.contrib.admin.options.ModelAdmin


Makes all fields of Practice visible on admin site.











algorithm Module


Implemements the spacing algorithm.



		
memorize.algorithm.calculateEasyFactor(oldEF, rating, repetition)[source]


		Calculate new easy factor from old factor and rating.



EF’ := f(EF,q)
where,



EF’ = new value of the easiness factor
EF  = old value of the easiness factor
q   = user difficulty rating (1-4)
f(EF,q)   = EF-0.8+0.28*q-0.02*q*q











		Parameters :		
		oldEF (float) –
An factor for calculating the next repetition interval.


		rating (int) –
Difficulty rating for the item in question. From 0 (impossible) to 5 (easiest).


		repetition (int) –
Number of repetitions until now.









		Returns:		int –
minutes until next practice
float: new easiness factor

















		
memorize.algorithm.calculateInterval(repetition, rating, easy_factor)[source]


		Calculate the inter-repetition interval



I(1):= r/2
I(2):= r
for n>2 I(n):=I(n-1)*EF




		where:


		I(n) - inter-repetition interval after the n-th repetition (in days)
EF - easiness factor reflecting the easiness of memorizing and retaining a given item in memory.
r - Rating, given by the user.


		The calculation is done recursively. Details at:


		http://www.supermemo.com/english/ol/sm2.htm


		The deviation from SM-2 consists in the following details:


		
		The default interval for the first and second repetition is not fixed to 1 and 6, but relative to
the user rating.















		Parameters :		
		repetition (int) –
Number of repetitions until now.


		easy_factor (float) –
easiness factor









		Returns:		int –
days until next practice

















		
memorize.algorithm.interval(repetition, rating, easy_factor=2.5)[source]


		Simplified SM-2 spacing algorithm.



		It is loosely based on the SuperMemo 2 algorithm. Details at:


		http://www.supermemo.com/english/ol/sm2.htm









		Parameters :		
		repetition (int) –
Number of repetitions until now.


		rating (int) –
Difficulty rating for the item in question. From 0 (hardest) to 4 (easiest).


		easy_factor (float) –
An factor for calculating the next









		Returns:		int –
minutes until next practice
float: new easiness factor



















models Module


Defines the Practice Model for keeping track of practice sessions.



		
class memorize.models.Practice(*args, **kwargs)[source]


		Bases: django.db.models.base.Model


This model saves the learning stats of a user linked to a specific item.


The Practice model uses the django.contrib.contenttypes.models.ContentType [http://django.readthedocs.org/en/1.5.x/ref/contrib/contenttypes.html#django.contrib.contenttypes.models.ContentType]
framework to link it to a generic other object. This way, it can be used to keep track of
learning progress of any other kind of model.



		
content_type ForeignKey


		PK of the learnable object









		
object_id int


		ID of the learnable object









		
item GenericForeignKey


		Combines the above.









		
started_last_viewing DateTimeField


		Starting time of the most recent learning.









		
ended_last_viewing DateTimeField


		Ending time of the most recent learning.









		
user User


		The user who is practicing.









		
next_practice DateTimeField


		Calculated next time of practice.









		
times_practice int


		Number of times the item has been practice by the user.









		
easy_factor float


		An arbitrary number roughly representing the difficulty of the item for
the user.









		
exception DoesNotExist


		Bases: django.core.exceptions.ObjectDoesNotExist









		
exception Practice.MultipleObjectsReturned


		Bases: django.core.exceptions.MultipleObjectsReturned









		
Practice.content_type


		






		
Practice.get_next_by_next_practice(*moreargs, **morekwargs)


		






		
Practice.get_previous_by_next_practice(*moreargs, **morekwargs)


		






		
Practice.item


		Provides a generic relation to any object through content-type/object-id
fields.









		
Practice.objects = <django.db.models.manager.Manager object at 0x7f7d6f155490>


		






		
Practice.user


		














views Module
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  Source code for memorize.admin

from django.contrib import admin
from models import Practice

[docs]class PracticeAdmin(admin.ModelAdmin):
    """Makes all fields of Practice visible on admin site.

    """
    list_display = Practice._meta.get_all_field_names()



admin.site.register(Practice, PracticeAdmin)
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authentication Package



models Module





tests Module


This file demonstrates writing tests using the unittest module. These will pass
when you run “manage.py test”.


Replace this with more appropriate tests for your application.



		
class authentication.tests.SimpleTest(methodName='runTest')[source]


		Bases: django.test.testcases.TestCase



		
test_basic_addition()[source]


		Tests that 1 + 1 always equals 2.

















urls Module





views Module



		
authentication.views.login(request, **kwargs)[source]
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  All modules for which code is available


		authentication.tests


		authentication.views


		memorize.admin


		memorize.algorithm


		memorize.models
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  Source code for authentication.views

# Create your views here.
from django.contrib.auth import views
from django.conf import settings

[docs]def login(request,**kwargs):
    response = views.login(request,kwargs.get('template_name'))
    if not hasattr(response, 'context_data'):
        response.context_data = {}
    response.context_data['secrets_present'] = settings.SECRETS_PRESENT
    return response
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cardbox Package



admin Module
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  Source code for authentication.tests

"""
This file demonstrates writing tests using the unittest module. These will pass
when you run "manage.py test".

Replace this with more appropriate tests for your application.
"""

from django.test import TestCase


[docs]class SimpleTest(TestCase):
[docs]    def test_basic_addition(self):
        """
        Tests that 1 + 1 always equals 2.
        """
        self.assertEqual(1 + 1, 2)
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manage Module
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"""Implemements the spacing algorithm.

"""

[docs]def interval(repetition, rating, easy_factor=2.5):
    """Simplified SM-2 spacing algorithm.

    It is loosely based on the SuperMemo 2 algorithm. Details at:
        http://www.supermemo.com/english/ol/sm2.htm

    Args:
     repetition (int): Number of repetitions until now.
     rating (int): Difficulty rating for the item in question. From 0 (hardest) to 4 (easiest).
     easy_factor (float): An factor for calculating the next

    Returns:
      int: minutes until next practice
      float: new easiness factor

    """
    if rating < 3:
        return 10, easy_factor
    elif rating == 3:
        return 30, easy_factor
    else:
        repetition, easy_factor = calculateEasyFactor(easy_factor, rating, repetition)
        repetition_interval = calculateInterval(repetition, rating, easy_factor)
        repetition_interval *= 1440 # delay() expects the interval in minutes, but calculateInterval() returns days.
        return repetition_interval, easy_factor


[docs]def calculateInterval(repetition, rating, easy_factor):
    """ Calculate the inter-repetition interval

        I(1):= r/2
        I(2):= r
        for n>2 I(n):=I(n-1)*EF

    where:
        I(n) - inter-repetition interval after the n-th repetition (in days)
        EF - easiness factor reflecting the easiness of memorizing and retaining a given item in memory.
        r - Rating, given by the user.

    The calculation is done recursively. Details at:
        http://www.supermemo.com/english/ol/sm2.htm

    The deviation from SM-2 consists in the following details:
        - The default interval for the first and second repetition is not fixed to 1 and 6, but relative to
          the user rating.

    Args:
     repetition (int): Number of repetitions until now.
     easy_factor (float): easiness factor

    Returns:
      int: days until next practice

    """
    if repetition < 0:
        raise ValueError, 'Repetition must be 0 at least!'

    if easy_factor < 1.3:
        raise ValueError, 'Easy factor must not be less than 1.3!'

    if repetition < 3:
        return rating/2
    elif repetition==3:
        return rating
    else:
        return calculateInterval(repetition-1, rating, easy_factor)*easy_factor


[docs]def calculateEasyFactor(oldEF, rating, repetition):
    """ Calculate new easy factor from old factor and rating.

     EF' := f(EF,q)
     where,
         EF' = new value of the easiness factor
         EF  = old value of the easiness factor
         q   = user difficulty rating (1-4)
         f(EF,q)   = EF-0.8+0.28*q-0.02*q*q

    Args:
     oldEF (float): An factor for calculating the next repetition interval.
     rating (int): Difficulty rating for the item in question. From 0 (impossible) to 5 (easiest).
     repetition (int): Number of repetitions until now.

    Returns:
      int: minutes until next practice
      float: new easiness factor

    """
    if oldEF < 1.3:
        raise ValueError, 'Easy factor must not be less than 1.3!'

    if rating not in xrange(0,6):
        raise ValueError, 'Rating must be positive and less than 6!'

    # If the card is rated < 2, the number of repetitions is reset.
    if rating < 2:
        repetition = 1

    # Calculate new easy facor using the SM-2 formula.
    newEF = oldEF - 0.8 + 0.28 * rating - 0.02 * rating * rating
    if newEF < 1.3:
        newEF=1.3

    return repetition, newEF
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  Source code for memorize.models

"""Defines the Practice Model for keeping track of practice sessions.

"""

from django.db import models
from django.contrib.auth.models import User
from django.contrib.contenttypes.models import ContentType
from django.contrib.contenttypes import generic

[docs]class Practice(models.Model):
    """This model saves the learning stats of a user linked to a specific item.

    The Practice model uses the :class:`django.contrib.contenttypes.models.ContentType`
    framework to link it to a generic other object. This way, it can be used to keep track of
    learning progress of any other kind of model.

    Attributes:
     content_type (ForeignKey): PK of the learnable object
     object_id (int): ID of the learnable object
     item (GenericForeignKey): Combines the above.
     started_last_viewing (DateTimeField): Starting time of the most recent learning.
     ended_last_viewing (DateTimeField): Ending time of the most recent learning.
     user (User): The user who is practicing.
     next_practice (DateTimeField): Calculated next time of practice.
     times_practice (int): Number of times the item has been practice by the user.
     easy_factor (float): An arbitrary number roughly representing the difficulty of the item for
      the user.

    """
    content_type = models.ForeignKey(ContentType)
    object_id = models.PositiveIntegerField()
    item = generic.GenericForeignKey('content_type', 'object_id')
    started_last_viewing = models.DateTimeField(null=True,blank=True, auto_now_add=True)
    ended_last_viewing = models.DateTimeField(null=True,blank=True, auto_now_add=True)
    user = models.ForeignKey(User)
    next_practice = models.DateTimeField(auto_now_add=True)
    times_practiced = models.PositiveIntegerField(default=0)
    easy_factor = models.FloatField(default=2.5)

    class Meta:
        ordering = ['next_practice']
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