

    
      
          
            
  
thnikk Keypad Documentation

Welcome! This is the documentation for all current models of my keypads.

Here you can find feature lists for models, guides to install drivers, remap the keys, and change your switches. This will be updated with my code so it should always be up to date!
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Buyer’s Guide

A lot of people have had a lot of questions about my keypads for determining which model and what parts would be better for them, so I’ll outline the differences here.


Switches

[image: _images/d4baf2b087.jpg]
This may be the most important choice you can make with your keypad. Luckily, you aren’t stuck with your choice thanks to the switch changing kit (unless you buy the LED model) so don’t feel too stressed out. It’s easy to say it’s “personal preference,” so I’ll instead try to give you some objective information that you can base your decision on.


Clicky

[image: _images/Cherry-mx-blue.gif]
These have both a bump and an audible click when the switch is pressed to its actuation point. This is nice for typing (especially touch typing) since it’s a clear indication that you’ve pressed the switch. It’s great for avoiding “bottoming out,” meaning the switch is fully depressed, which can help reduce fatigue from typing over long periods of time.

However, playing osu! is not the same as typing. The game is much more hectic and if you try to feel or listen to the click, you will be pulling your atention away from the game. Some players may be able to take adavantage of the click, but I consider it to be very disadvantageous. It would be a nice option for a macro keypad if you want to use it for professional applications, but be mindful if you want to use it with other people around.




Tactile

[image: _images/Cherry-mx-brown.gif]
These offer the same benefit that blues do for typists, but the same downisde for osu players. They have the same bump at the actuation point but no audible click. These would also be nice for professional applications and are better in quiet environments.




Linear

[image: _images/Cherry-mx-red.gif]
Liear switches offer a nice variety in weight (actuation force) and don’t have any audible click or tactile bump. I would consider these the best for osu! and gaming use in general.




Actuation Force Table




Cherry MX VS Gateron

[image: _images/924542bfac8d54374e7adbede6c048c9b204c699.jpg?auto=format&fm=jpg&fit=crop&w=1023&dpr=1]
One other thing to mention is the difference between Gateron and Cherry switches. Cherry is a German company that’s been making these for a long time, but their patent ran out recently so a bunch of other companies started making MX clones. Among those companies is Gateron. They are considerably smoother feeling, where Cherry’s switches have a bit of a scratchy feel to them.




Cherry MX Silver

Though MX silvers (also referred to as MX Speed switches) have the same actuation force as MX reds, there are two key differences that set them apart. The first is their higher actuation point, at 1.2 mm instead of the 2 mm on a normal Cherry MX switch. This means the key will be detected as pressed much higher in the keystroke, but I think the same caveat exists that does with tactile/clicky switches. In a hectic gaming scenario, particularly with playing a rhythm game, it won’t make a difference if you’re bottoming out the keys. However, the second difference is that they bottom out at 3.4 mm instead of the typical 4 mm, which means it should have an impact (no matter how minuscule) whether you bottom out the keys or not.




Touch Keypad

This isn’t a switch, per se, but I think it’s worth including here just as a reminder that it’s an option. There are a few advantages to the touch keypad:



	It’s actually silent. You’re not pressing anything that moves, so it should be very similar to tapping directly on your desk but with a little extra padding thanks to the micro-suction tape on the bottom of the keypad.


	It’s small. The regular touch models are small enough to not even notice in a bag and the MegaTouch models are a bit bigger, but still thin enough to fit in a small backpack pocket without being bulgey.


	The travel distance is effectively zero. If you normally hover over your mechanical keys, this is worth considering since not only do you need to push down until your fingers touch the keycaps, but they have to continue to push the key down to the actuation point and maybe even to bottom out the switch, which can easily be ~5 mm. The touch models detect your fingers on contact so the only finger movement is to make contact with the pads.







There’s a bit of a learning curve. If you play any mobile rhythm games and don’t mind the feel, and especially if you turn off hit sounds like me, I think it’s a no-brainer and the adjustment period should be very short for you.






Keycaps

[image: _images/1f1l3yv.png]

DCS

DCS keycaps are what you’ll most commonly find on mechanical keyboards. They feature a subtle curve vertically that your finger can rest in and an angle depending on the row. They are comfortable for both typing and osu, but you have to be a bit more precise with your button presses.




DSA

DSA keycaps are a little more rare but offer a completely flat profile across all keyboard rows. This makes it easy to get a whole bunch of blank ones since all 1x keycaps are the same, unlike the DCS keycaps that differ by row. They have an old-fasioned look to them and feature a slight concave curvature on the top of the key. They work well for osu but less for typing on a keyboard since the flatness of them makes them less ergonomic.




Flat

[image: _images/C0LONW6UsAAjMPt.jpg]
Flat keycaps are the least common by far. I bought a few from pimpmykeyboard.com a year or two ago and loved them, but they were a bit too expensive so I figured nobody would want to pay $4+ for them. Fast forward to 2017 and I have a bit more experience in 3D printing. Now I can offer them not only as a cost saving measure to both you and myself, but also be happy that they work well and provide a very nice experience in osu.

These offer two major improvements over DCS and DSA keycaps. They expand the surface area of the top of the key to their maximum, giving you more leeway with where you press. They also allow me to have better control of both the travel distance and the max height of the keypad, which means that your hand won’t have to rest at as high of an angle which should result in a more comfortable experience over long sessions.









          

      

      

    

  

    
      
          
            
  
Quickstart Guide

Contratulations on receiving your keypad! This quick guide will walk you through how to use your keypad.


What’s in the box:

[image: http://www.thnikk.moe/docs/quickstart/box.jpg]

	Keypad


	Keycaps


	Cable







Before use…

There are two things that should be done before you use your keypad.


Installing the Keycaps

[image: http://www.thnikk.moe/docs/quickstart/pressed.jpg]
To install the keycaps, put them on top of the switches in the correct orientation and push them down.

[image: http://www.thnikk.moe/docs/quickstart/oring.jpg]
O-rings come pre-installed on the keycaps so there is no need to isntall them manually. If you don’t like the soft feel and reduced travel of the keys, they can be removed.




Remove Tape Film

[image: http://www.thnikk.moe/docs/quickstart/tape.jpg]
The tape on the bottom of the keypad will fix it to your desk so it doesn’t move around during play. This tape has a film covering it that must be removed to expose its stickiness.






More (Optional)

These are some other things you can do after you get your keypad up and running.


Setting the LED mode

While the basic model’s side button is used exclusively as an escape key, it serves an additional purpose on all models with LEDs. By holding the button down and waiting for the LEDs to blink, you can change the LED mode. Wait for it to blink twice for the secondary action, which is for changing the brightness (or the colors on the custom mode.) For more info on LED modes and the side button for your keypad, please visit the models page here:

Models [http://docs.thnikk.moe/en/latest/models.html]




Remapping and Reprogramming

If you’re unhappy with the default zx(cv) button mapping of your keypad, visit this page to learn how to easily remap the buttons!

How to remap the buttons on your keypad. [http://docs.thnikk.moe/en/latest/remap.html]

If you’d like to change the functionality of the keypad, I have a reprogramming guide that you can visit here.

How to reprogram your keypad. [http://docs.thnikk.moe/en/latest/program.html]

If you wish for any aditionaly functionality, I would appreciate it if you opened an issue on my GitHub.

GitHub [https://github.com/thnikk/newKeypad]




Changing Your Switches

If you’re unhappy with your original choice of switches, a switch changing kit can be purchased from my shop! A guide for how to use the kit can be found here.

Switch Changing Kit [http://docs.thnikk.moe/en/latest/switch.html]









          

      

      

    

  

    
      
          
            
  
Keypad Models


Basic Keypad

[image: _images/il_fullxfull.1453471138_pc57.jpg]
A simple 2-key keypad. This was previously the “no bells and whistles” model, but now features a bottom-mounted RGB LED that adds some RGB underglow to the keypad!  The side button functions as escape and is also used to change LED modes and the color of the keys on the “custom” LED mode.


Side button functionality







	Hold time

	Functionality





	Less than 0.5s

	Escape



	0.5 - 1.5s

	Change LED mode



	more than 1.5s

	Change brightness (Press Z to lower and X to raise)



	more than 1.5s (on custom LED mode)

	Change color per-key









LED modes







	Order

	Mode





	1

	Cycle - Fades through rainbow.



	2

	Reactive - Turns LEDs on when pressed and fades from red to green to blue to off when released.



	3

	Push Off - LEDs are normally white and fade from red to green to blue to off when the keys are pressed.



	4

	Custom - LED color can be set per-key.



	5

	BPM - LEDs turn white when pressed and change color depending on how much you hit them per second when released.



	6

	Color Change - Colors cycle in steps per-press per-key.











Touch Keypad

[image: _images/il_1140xN.1721382343_fx24.jpg]
A 2-key keypad that uses two capacitive metal pads instead of switches, which results in faster key presses (by removing key travel) and a slimmer keypad. It features LED modes specifically rewritten for this model and a side button that is… a screw? The side screw is just like the two top keys and will press the mapped key when touched (escape by default.)

Unlike the non-touch models, all configuration of the keypad can be done using a program like Termite and all settings will be saved to the keypad. This frees up the side button to function as a regular key and it can be remapped just like the top buttons.


LED modes







	Mode

	Description





	Cycle

	Fades through rainbow; White when key is pressed; Off when side button is pressed



	Reactive

	Turns to white when pressed and fades through r>g>b>off when released



	Reactive Inverted

	Fades through r>g>b>off when pressed and turns to white when released



	Color Change

	Colors cycle in steps per-press per-key.



	BPS

	Color changes depending number of keypresses per second and turns white while key is pressed



	Custom

	LED uses user-specified color (can be set through Termite)



	Off

	LED is turned off











MegaTouch Keypad

[image: _images/il_1140xN.1673915594_mvj8.jpg]
A larger version of the 2K touch keypad. It features 60% larger touch pads (1 1/4” squares) with the same gap as the normal model, so it’s great whether you just want a larger touch area or you play with your index+ring fingers! It’s still just as slim at only 12 mm tall and is just as big as it needs to be to accommodate the touch pads. The side screw still functions as a capacitive button and is mapped to Escape by default, but can be easily remapped to something like ~ for quick restart. Configuration of LED modes and brightness can be done through the software remapper.


LED modes







	Mode

	Description





	Cycle

	Fades through rainbow; White when key is pressed; Off when side button is pressed



	Reactive

	Turns to white when pressed and fades through r>g>b>off when released



	Reactive Inverted

	Fades through r>g>b>off when pressed and turns to white when released



	Color Change

	Colors cycle in steps per-press per-key.



	BPS

	Color changes depending number of keypresses per second and turns white while key is pressed



	Custom

	LED uses user-specified color (can be set through Termite)



	Off

	LED is turned off











RGB Keypad

[image: _images/il_fullxfull.1453472428_dekw.jpg]
A fancier version of the basic model that features not only the bottom-mounted LED, but also an RGB LED under each key. This makes for much brighter and more prominent lighting effects. The side button functions as escape and is also used to change LED modes, brightness, and the colors of the keys on the “custom” LED mode.


Side button functionality







	Hold time

	Functionality





	Less than 0.5s

	Escape



	0.5 - 1.5s

	Change LED mode



	more than 1.5s

	Change brightness (Press Z to lower and X to raise)



	more than 1.5s (on custom LED mode)

	Change color per-key









LED modes







	Order

	Mode





	1

	Cycle - Fades through rainbow.



	2

	Reactive - Turns LEDs on when pressed and fades from red to green to blue to off when released.



	3

	Push Off - LEDs are normally white and fade from red to green to blue to off when the keys are pressed.



	4

	Custom - LED color can be set per-key.



	5

	BPM - LEDs turn white when pressed and change color depending on how much you hit them per second when released.



	6

	Color Change - Colors cycle in steps per-press per-key.











Basic 4K Keypad

[image: _images/il_fullxfull.1453474430_re6k.jpg]
A 4-key version of the RGB keypad made for use with Taiko and Mania. Like the 2K basic model, this was previously the “no bells and whistles” model, but now features a bottom-mounted RGB LED that adds some RGB underglow to the keypad!  The side button functions as escape and is also used to change LED modes and the color of the keys on the “custom” LED mode.


Side button functionality







	Hold time

	Functionality





	Less than 0.5s

	Escape



	0.5 - 1.5s

	Change LED mode



	more than 1.5s

	Change brightness (Press Z to lower and X to raise)



	more than 1.5s (on custom LED mode)

	Change color per-key









LED modes







	Order

	Mode





	1

	Cycle - Fades through rainbow.



	2

	Reactive - Turns LEDs on when pressed and fades from red to green to blue to off when released.



	3

	Push Off - LEDs are normally white and fade from red to green to blue to off when the keys are pressed.



	4

	Custom - LED color can be set per-key.



	5

	BPM - LEDs turn white when pressed and change color depending on how much you hit them per second when released.



	6

	Color Change - Colors cycle in steps per-press per-key.











4K Touch Keypad

[image: _images/VrA3h71.jpg]
Looking for something slimmer, quieter, more portable, or all three? This 4-key keypad primarily for Mania and Taiko uses two capacitive pads instead of switches, which results in faster key presses (by eliminating key travel) and a slimmer design. It features LED modes specifically rewritten for this model and a side button that is… a screw? The side screw is just like the two top keys and will press the mapped key when touched (escape by default.)

Unlike the non-touch models, all configuration of the keypad can be done using a program like Termite and all settings will be saved to the keypad. This frees up the side button to function as a regular key and it can be remapped just like the top buttons.


LED modes







	Mode

	Description





	Cycle

	Fades through rainbow; White when key is pressed; Off when side button is pressed



	Reactive

	Turns to white when pressed and fades through r>g>b>off when released



	Reactive Inverted

	Fades through r>g>b>off when pressed and turns to white when released



	Color Change

	Colors cycle in steps per-press per-key.



	BPS

	Color changes depending number of keypresses per second and turns white while key is pressed



	Custom

	LED uses user-specified color (can be set through Termite)



	Off

	LED is turned off











4K RGB Keypad

[image: _images/il_fullxfull.1453479854_nb4u.jpg]
A fancier version of the basic 4K keypad made for use with Taiko and Mania. This model that features not only the bottom-mounted LED, but also an RGB LED under each key. This makes for much brighter and more prominent lighting effects. The side button functions as escape and is also used to change LED modes, brightness, and the colors of the keys on the “custom” LED mode.


Side button functionality







	Hold time

	Functionality





	Less than 0.5s

	Escape



	0.5 - 1.5s

	Change LED mode



	more than 1.5s

	Change brightness (Press Z to lower and X to raise)



	more than 1.5s (on custom LED mode)

	Change color per-key









LED modes







	Order

	Mode





	1

	Cycle - Fades through rainbow.



	2

	Reactive - Turns LEDs on when pressed and fades from red to green to blue to off when released.



	3

	Push Off - LEDs are normally white and fade from red to green to blue to off when the keys are pressed.



	4

	Custom - LED color can be set per-key.



	5

	BPM - LEDs turn white when pressed and change color per-key depending on how much you hit them per second when released.



	6

	Color Change - Colors cycle in steps per-press per-key.











7K RGB Keypad

[image: _images/il_fullxfull.1682539033_e7fs.jpg]
A keypad made for 5K and 7K osu!Mania. This keypad features seven LEDs for interesting LED modes and full NKRO. The bottom key uses a 2x width angled keycap for better ergonomics. There is also a multi-function key (this is the same as the side button on my other models) that can be used to either configure your keypad or as a simple escape key.


Multi-function button







	Hold time

	Functionality





	Less than 0.5s

	Escape



	0.5 - 1.5s

	Change LED mode



	more than 1.5s

	Change brightness (Press key 1 to lower and key 2 to raise while holding the button)



	more than 1.5s (on custom LED mode)

	Change color per-key









LED modes







	Order

	Mode





	1

	Cycle - Fades through rainbow.



	2

	Reactive - Turns LEDs on when pressed and fades from red to green to blue to off when released.



	3

	Push Off - LEDs are normally white and fade from red to green to blue to off when the keys are pressed.



	4

	Custom - LED color can be set per-key.



	5

	BPM - LEDs turn white when pressed and change color per-key depending on how much you hit them per second when released.



	6

	Color Change - Colors cycle in steps per-press per-key.











Macropad

[image: _images/il_1140xN.1525490161_hbhf.jpg]
By popular request, I made a keypad focused less on crazy lights and more on people that want the ability to quickly switch between button mappings. This model features not only the ability to map each key to up to 3 keys, but also six “pages” of mappings that you can change by holding the side button and pressing one of the six keys. It also has a single RGB LED to show the current page.


Side button functionality







	Hold time

	Functionality





	Less than 0.5s

	Escape



	More than 0.5s

	Change mapping page (1-6 depending on face button pressed)









Default button mapping







	Page

	Keys





	1

	A, S, D, Z, X, C



	2

	Q, W, E, A, S, D



	3

	blank, up, blank, left, down, right



	4

	1, 2, 3, 4, 5, 6



	5

	all blank



	6

	all blank













Upon Request


Future Tone Controller

[image: _images/il_fullxfull.1360528126_hpn6.jpg]
This is the small controller I made for Hatsune Miku: Project Diva Future Tone for PS4. There is a mode select button on the front of the controller that allows you to switch between DS4 and arcade mode. DS4 mode maps the buttons to the standard DS4 layout and arcade mode maps the keys in a horizontal layout like you’d get on the arcade cabinet. This makes hold notes a lot more natural wihout sacrificing speed since the arrow buttons are all adjacent to their corresponding buttons. When the mode is changed, the LEDs change color to match the corresponding layout.

[image: _images/il_fullxfull.1407795821_2vpk.jpg]
[image: _images/il_fullxfull.1407795827_4g75.jpg]





Discontinued


LED Keypad

[image: _images/2kled.png]
This is the LED model. It features a white LED on each of the two face keys. The side button functions as escape and is also used to change LED modes and brightness.


Side button functionality







	Hold time

	Functionality





	Less than 0.5s

	EscapeA 4-key version



	0.5 - 1.5s

	Change LED mode



	more than 1.5s

	Change brightness (Press Z to lower and X to raise)









LED modes







	Order

	Mode





	1

	Reactive - Turns LEDs on when pressed and fades out when released.



	2

	Push Off - Turns LEDs off when pressed and fades on when released.



	3

	Breathe - Fades LEDs in and out.



	4

	On - LEDs stay on.



	5

	Off - LEDs stay off.














          

      

      

    

  

    
      
          
            
  
Driver Installation


Windows 8.1 or lower

Before we get started with any remapping or programming, you’ll need the driver for the keypad installed.

Adafruit Drivers [https://github.com/adafruit/Adafruit_Windows_Drivers/releases/download/2.2.0/adafruit_drivers_2.2.0.0.exe]

You can install all of the drivers if you’d like, but only the “Feather 32u4, Feather M0, Feather M0 Express…” option is necessary.


For keypads purchased before 3/15/18

Arduino Leonardo Drivers [http://puu.sh/tg52G/f1255ee469.zip]

Download and extract the zip to your desktop and open “dpinst-amd64.exe.” Follow the wizard and say yes when it asks. That’s it!






Windows 10, Mac, and Linux

No driver installation required. You’re done, great job!







          

      

      

    

  

    
      
          
            
  
Remapping Your Keypad


Windows

If you are on Windows 8.1 or lower and you haven’t already, follow the driver installation guide first.

Driver Installation [http://docs.thnikk.moe/en/latest/driver.html]

Once the drivers are installed, download and extract Termite. You want to make sure you extract since you need to run it with the .ini file in the same directory.

Download Termite [https://puu.sh/w8Zj5/01aa028013.zip]

Upon opening the program, it should immediately connect to the keypad. Follow the directions in the remapper and you’re all set!


	If you have any problems, make sure your settings match these (except for the port since it may be different for you): http://puu.sh/C8hhI/6d005fdf84.png




Make sure to close Termite when you’re done, otherwise it may try to reconnect and lock up your keypad.




Mac and Linux

The procedure for Mac and Linux is the same since we’ll be using the screen command on both. As we do on windows, you’ll first need to find the com port the keypad is using. You can do so by entering this into the terminal:

dmesg | grep tty

If you just plugged the keypad in, it should be the last thing listed. In my case it’s using /dev/ttyACM0. Now we can start serial communications using screen.

screen /dev/ttyACM0 9600

That’s it!




Universal

You can also use the Serial Monitor included in the Arduino IDE. This can be done by downloading the IDE through the Arduino website here:

Download [https://www.arduino.cc/en/Main/Software]

Follow the wizard for installation and launch the program. From here you can select the port from Tools > Ports and open the Serial Monitor by clicking the magnifying glass icon in the top right of the window.







          

      

      

    

  

    
      
          
            
  
Programming Your Keypad


PlatformIO


What is it?

PlatformIO is an IDE like the Arduino IDE but is integrated with your text editor!




Download Atom

Download and install Atom from here: https://atom.io/




Install PlatformIO

Launch atom and press ctrl and comma which will open the settings menu. Click on install, type “platformio” into the search box and hit enter. Click install on “platformio-ide” and wait for it to install. It should ask if you want to install clang for auto-completion but it’s not necessary so you can just ignore it. When the installation finishes, you should see a button in the top right that tells you to restart to apply the changes. Hit restart and you’re good to go!




Download the Code

Click the link for your respective model to go to the GitHub page that contains the necessary code. Click the “clone or download” button and then select “download zip.” Extract it to wherever you like (I would recommend your desktop or documents folder.)


	Basic/RGB 2K/4K [https://github.com/thnikk/trinketM0]


	7K Keypad [https://github.com/thnikk/7kKeypad]


	MacroPad [https://github.com/thnikk/trinketM0Macro]


	Touch Keypad [https://github.com/thnikk/touchPad]







Uploading the code

[image: _images/d4507e79bb.png]
Open the folder in Atom that you just extracted from the zip that contains the “platformio.ini” file and it should show up in the left panel under “Project.” It should be called <code>-master, but make sure it’s the one that contains platformio.ini since there can be two of the folders depending on how you extracted the zip. Click on the folder with the same title as the parent folder and open the file with the same title with the .ino extension (which should be something like trinketM0-master > trinketM0 > trinketM0.ino, the names will be different depending on the code you’re using). Make sure your keypad is plugged in and press F7. Type “upload” and select the correct option for your model (if you don’t select the model, it will try to upload all of them so make sure to do this.) You may need to try a few times and if it tells you that it can’t find the port, just try unplugging the keypad and plugging it back in. If all goes well, it should upload the code to the keypad!








ONLY for keypads purchased before 3/15/18


The Easy Way (Web Editor)

Arduino recently introduced their web-based editor, a more accessible version of the Arduino IDE that can run in your web browser. This is great for me because it’s a lot easier than installing the program, libraries, copying and pasting code, selecting the port, selecting the board, etc. Don’t worry about any of that, since we get to avoid all of it!


Requirements

Browser: Chrome, Firefox, or Safari

Arduino account




Making an Arduino Account

Don’t worry, they won’t bombard you with emails (yet*) and you don’t need to give them any personal information, they just require an account so you can manage your code. You can make your account from this page here:

Sign Up [https://id.arduino.cc/auth/signup]

You will have to verify your account through your email (don’t use a fake one) and then you’re done!




Installing the browser plugin

Go to the Web Editor [https://create.arduino.cc/editor] and you will be asked to install the plugin.

[image: _images/8c567035ed.png]
*On the welcome screen there’s a box you have to uncheck if you don’t want their emails:

[image: _images/6fcbdbad99.png]



Drivers?

If you’re on a Windows machine running Windows 8.1 or lower you’ll need drivers for your keypad to be recognized. The Arduino plugin should ask you to install them, but if it doesn’t, you can follow my driver installation guide here:

Driver Installation [http://docs.thnikk.moe/en/latest/driver.html]




Code

You’re almost done, all that’s left is loading the code. Fortunately, they have made this very easy. All you have to do is click on the share link for your corresponding keypad and add to sketchbook. It should then take you to the editor and tell you that Arduino Leonardo has been connected. You can now click on Upload (the right arrow) to upload the code to the keypad. If it works, you should see “Success: Done Uploading.” If not, make sure the keypad is plugged in and that you installed the drivers.

[image: _images/df51db652d.png]
Basic [https://create.arduino.cc/editor/thnikk/26f18039-32be-4fe3-a009-4e23419a6454/preview]

LED [https://create.arduino.cc/editor/thnikk/17b2c815-21e5-4f83-8b49-a9630c99a6a8/preview]

RGB [https://create.arduino.cc/editor/thnikk/eefe8ac7-c0d8-4695-8ec6-2199418b001c/preview]

4K [https://create.arduino.cc/editor/thnikk/e137af8a-9e23-41fb-8e6c-0f7de12ac20a/preview]

4K RGB [https://create.arduino.cc/editor/thnikk/730ced35-bc57-4b74-8e8e-05a4c5d64942/preview]

MacroPad [https://create.arduino.cc/editor/thnikk/469813aa-c98b-4555-b071-00e8ac409226/preview]






The Hard Way (Desktop IDE)

If you don’t want to use the Web IDE, you can download the tried-and-true desktop IDE instead. This is a little harder and requires a few extra steps, but you don’t need to make an account.


Driver Installation

If you’re on a Windows machine running Windows 8.1 or lower you’ll need drivers for your keypad to be recognized.

Driver Installation [http://docs.thnikk.moe/en/latest/driver.html]




Installing the Arduino IDE

The latest version of the Arduino IDE can be downloaded and installed from the Ardiono website here:

Arduino.cc [https://www.arduino.cc/en/Main/Software]




Configuring the IDE

A few things need to be done before you start. Firstly, you will need the libraries used in the code, otherwise it can’t compile because all of that code will be missing. This used to be a lot more difficult to install, but since version 1.6.5 they added the Library Manager, which allows you to install libraries directly from the IDE. To install libraries, launch the IDE open the Library Manager by going to Sketch > Include Library > Manage Libraries…

[image: _images/libman.jpg]
My code uses the Bounce2 and NeoPixel libraries, so just search “Bounce2” and “Adafruit NeoPixel” in the search bar and click Install on the result. After they are installed, you can close the Library Manager window.




Verifying and Uploading the Code

Delete the code in the main window of the Arduino IDE. Now, paste in the code for your corresponding keypad from my GitHub here:

GitHub [https://github.com/thnikk/newKeypad]

Now we need to tell the IDE what it’s trying to compile for and communicate with. Go to Tools > Board and select Arduino Leonardo and go to Tools > Port and select the one that has (Arduino Leonardo) to the right of it.

[image: _images/board.jpg]
Now you can click on the right arrow to compile and upload the code. Don’t worry about uploading broken code, if it fails to compile it won’t upload it to the microcontroller. It will ask you to save and you can either click cancel or choose a directory to save to, it will compile either way. If you didn’t get any errors, congratulations, you did it! If you did, make sure you’ve selected the board and the port and that there’s nothing left behind from the blank sketch or that you copied the code correctly.








Making Changes to the Firmware

There are some things you should familiarize yourself with before you get started. These are the most important functions/libararies.

digitalRead() [https://www.arduino.cc/en/Reference/DigitalRead] for reading button inputs.

analogWrite() [https://www.arduino.cc/en/Reference/AnalogWrite] for controlling single-color LEDs.

The neopixel library [https://learn.adafruit.com/adafruit-neopixel-uberguide/arduino-library] for controlling RGB LEDs.

for loops [https://www.arduino.cc/en/Reference/For]

switch/case statements [https://www.arduino.cc/en/Reference/SwitchCase]

millis timers [https://learn.adafruit.com/multi-tasking-the-arduino-part-1/using-millis-for-timing]

I wouldn’t recommend trying to change random variables unless you can actually follow the logic and see exactly what they’re changing. Some of them may tie in somewhere else and cause unexpected results.





          

      

      

    

  

    
      
          
            
  
Changing Your Keypad’s Switches


Overview

This guide will walk you through swapping the internals of a Cherry MX compatible switch with another one. This is meant to be simpler than replacing the entire switch, which would require resoldering. This still gives the desired effect but lets things like RGB LEDs be mounted on the back of the switch without having to replace them when you want to change the switch.




What You’ll Need

[image: _images/parts.png]

	-A switch changing kit:

	Fine-point tweezers, Small spudger (for keeping one side of the switch open), Cherry MX compatible switches





-A keypad




Opening the switches on your keypad

Before starting, I’d like for you to take a close look at the switch you want to open. In the four corners, you should see four rectangular indentations. Along the outside edge of these indentations, there are narrow slits. These slits lead all the way down the clamps of the switches, so when you insert something like tweezers into them, it straightens them out and helps you open the switch more easily. With that in mind, we can now move on.

[image: _images/open.png]
Insert your tweezers into the slits in the rectangular indentations of one side of the switch. There should be a poitn where you feel them go down a little bit more than if they weren’t in the slits. From here you can push the tweezers towards the center of the switch and one side should pop open!

[image: _images/open2.png]
We’ll be repeating the same step for the other side, but use the spudger to hold the open side of the switch open, otherwise it will close when you try to open the other side. Now you can remove the top, stem, and spring of the switch.




Opening the loose switches

This is a little simpler than opening the switches on the keypad since you have access to the tabs that hold it together from the underside. Grip the switch from the top and push the tweezers under the two tabs of one side of the switch. Tilt the tweezers up and one side of the switch should be open.

[image: _images/open3.png]
Opening the other side of the switch should also be easier. I use my fingers to firmly grip the open sides of the switch and repeat the first step. With enough pressure, the open side should stay open. With both sides open, we can now remove the stem and spring and insert them into the switch on the keypad!

These parts do have a correct orientation, so make sure the side of the stem that sticks out is facing the metal leaf in the switch. The top also has a correct orientation. The side with the cavity on the top should line up with the leaf (this only fits one way, so don’t force it if the switch isn’t closing.)

[image: _images/stemfit.png]
If all went well, your switch should now be changed!

[image: _images/done.png]






          

      

      

    

  

    
      
          
            
  
Troubleshooting Guide

This guide will walk you through steps to either get your keypad back up and running or properly diagnose the problem.


Connection


Keypad won’t turn on

This is usually caused by a problem with the USB connection. You can tell if your keypad is receiving power by looking for a faint red glow from the power LED inside.



	Check your cable and make sure it’s plugged in all the way on both ends.


	Try a different cable.


	Check your micro-USB port to see if it’s still connected to the board. In some exteme cases, it might have been ripped off.










USB device not recognized

This can be caused by a number of things, the most common two being a bad USB connection or a corrupted/incorrect bootloader.



	Follow the steps for the previous issue


	If you’ve recently tried uploading new code, open the keypad and quickly short the GND and RST pins twice. This will force it back into bootloader mode and you should be able to reupload your code. Make sure you have the correct board selected.










Shows up in Device Manager but it still isn’t working



	Make sure you don’t have a serial monitor open anywhere that may be falsely triggering the keypad to enter remap mode.


	Try following the reprogramming guide to get the stock code back on the keypad.










The remapper isn’t working with Termite

This is most commonly caused by having the Arduino Create plugin running. You can either disable it through the system tray in the bottom right or you can just use the Arduino Create serial monitor.






Mechanical


One of my switches isn’t working consistently

Try removing the o-rings from the keycaps to see if they are preventing the keys from being fully depressed.






Programming


It’s not compiling and giving me an error



	Enable verbose output for compilation and uploading under File>Preferences.


	Make sure you installed the required libraries (bounce2 and neopixel) under Sketch>Include Library>Manage Libraries…










It won’t upload

Make sure that you have the correct board and port selected.You need to select Arduino Leonardo under Tools>Boards and the port should be labeled with (Arduino Leonardo) next to it under Tools>Ports.






Remapping (on Remapper 1.1)


The keys I enter aren’t mapping properly


	Make sure you’re entering your modifiers first.


	Make sure you’re only entering three keys (including modifiers.)


	Enter xx (lowercase) after entering a modifier if you don’t wish for any additional keys to be mapped to that key. Otherwise, enter the remaining keys.
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Summary

About a month before Future Tone came out, I really wanted a controller for the game. I had just bought my PS4 and was planning on getting my first 3D printer. I decided to try to make an arcade-style controller using the PCB out of a dualshock 4 as well as the touchpad.

Someone suggested to me that I should try making something smaller.




Getting Started with the Future Tone Controller


Buttons

The keypad features all buttons of a standard dualshock 4 controller minus the analog sticks. It is made to be compatible with Hatsune Miku Project Diva Future Tone as well as Project Diva X.




Layout Switching

The mode button on the controller lets you switch the layout of the buttons. By pressing and releasing the button, you can change between Arcade and DS4 layout. Arcade layout is made to be similar to the Arcade version of the game if you are used to or prefer the buttons to be in a horizontal orientation. All buttons with the same color are diagonally adjacent to one another so you can still alternate quickly, but it does take some practice to get used to. DS4 layout is identical to the default layout of the DualShock 4.

To avoid confusion, I would recommend resetting the in-game mapping back to default so both modes are correct.




LEDs

The LEDs follow the selected layout, so the colors will change depeding on the mode.




Changing Brightness

To change the brightness of the LEDs on the controller, hold the mode button and press up or down. This follows the selected layout.




Timeout

Since the controller is using Brook’s PS4 Fight Board, Sony may push an update that makes it disconnect after 8 minutes. This can be fixed by updating to the latest firmware from Brook that can be found here:

link

They are usually very fast to push out updates but you may want to wait a day to update your system just in case.


	List


	list


	list
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Getting Started with the MacroPad


Macro Pages

The MacroPad currently allows you to set 6 pages of macros, and each macro can be 1-3 keys. This is great if you want to be able to switch between several productivity-oriented programs that use keyboard shortcuts. It can also be used to switch between work and game profiles, and even multiple games if they use different keys. You can also get more creative and use AutoHotKey (on Windows) to do even more with your macros.




Side Button

By quickly pressing the side button, it will function as a simple escape key. If you hold it until the LED blinks white, you can press one of the 6 keys to switch between the 6 pages.




RGB LED

The LED serves a few purposes. Most of the time, it’s going to show you the active page represented by a color. It will blink when you hold the side button down to show you that it’s ready to change pages, and it will cycle when you open the remapper.




Changing Macros
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How to connect the Plugin to Arduino Web Editor
Do you see the Arduino Plugin Icon in your top or bottom tray?

'YES:Make sure the icon is Black and not Grey. If Grey, click on it and select
“Open Plugin’

NO:Launch the Plugin as you would do for any program on your OS,
searching for ‘Arduino Create Agent".

You might be missing a Firefox HTTPS Certificate
Download the Pluzin azain to solve this problem This
Plugin will replace the old one.

stillnot able to use the Plugin? Report a bug or ask a question on our forum.
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